聚丰项目 > 智能猪舍

智能猪舍

1.生猪疾病预警 2.猪舍环境监测与控制 3.生猪养殖数据库 4.以科学生猪养殖技术为理论指导,实时监测猪舍环境温度、湿度,实现猪舍环境绿色调控。 5.实时云端大数据分析: 6.区域内猪场季节性、传染性生猪疾病能进行提前预警; 7.有利于兽医工作人员对生猪病情分析与对症治疗; 8.为健康生猪养殖产业研究提供有力依据。 9.提高生猪养殖户的规模效益 10.降低生猪养殖户的养殖风险 11.远程监控,实时了解猪舍状况 12.降低人力成本,提高经济效益

ctt1996 ctt1996

0 喜欢这个项目
团队介绍

ctt1996 ctt1996

团队成员

蔡涛涛

项目简介
1.生猪疾病预警 2.猪舍环境监测与控制 3.生猪养殖数据库 4.以科学生猪养殖技术为理论指导,实时监测猪舍环境温度、湿度,实现猪舍环境绿色调控。 5.实时云端大数据分析: 6.区域内猪场季节性、传染性生猪疾病能进行提前预警; 7.有利于兽医工作人员对生猪病情分析与对症治疗; 8.为健康生猪养殖产业研究提供有力依据。 9.提高生猪养殖户的规模效益 10.降低生猪养殖户的养殖风险 11.远程监控,实时了解猪舍状况 12.降低人力成本,提高经济效益
硬件说明

1.单片机部分:

介绍:

ST15系列单片机是STC生产的单时钟/机器周期()T)的单片机,是高速/高可靠/低功耗/超强抗干扰的新一代8051单片机,采用STC第八代加密技术,无法解密,指令代码完全兼容传统8051,但速度快8~12倍。内部集成高精度R℃时钟,ISP编程时5MHz、35MHz宽范围可设置,可彻底省掉外部昂贵的晶振和外部复位电路。3路CCP/PWM/PCA,8路高速10位A/D转换,内置2K字节大容量SRAM,2组超高速异步串行通信端口(UART1/UART2),可在5组管脚之间进行切换,分时复用可作5组串口使用,1组高速同步串行通信端口SPI,针对多串行口通信/电机控制/强干扰场合。在KeilC开发环境中,Intel8052编译,头文件包含<reg51.h>即可现STC巧系列单片机采用STC一Y5超高速CPU内核,在相同的时钟频率下,速度又比STC早期的IT系列单片机(如STC12系列/STCII系列/STCIO系列)的速度快20%.

功能:

通过IIC通信读取传感器的数据并处理传输到8266服务器。

2.

介绍:

网络数据交换部分:ESP8266,体积超小的802.11b/g/n Wi-Fi SOC 模块,采用低功率32位CPU,可兼作应用处理器,主频最高可达160MHz,支持串口,支持多种休眠模式,待机功耗低至1.0mW,通用AT指令可快速上手。

功能:将单片机串口传输的数据上传到服务器,并将服务器的指令传输到单片机执行。

3.

介绍:

IDT HS300x系列是一种高精度、全校准的相对产品湿度和温度传感器。MEMS传感器的特点是a独有的传感器级保护,确保高可靠性和高可靠性长期稳定。集成校准和温度补偿逻辑提供通过标准I2C完全校正RH和温度值输出。不需要用户校准输出数据。精度高,测量响应时间快,寿命长稳定性与小包装尺寸相结合使得HS300x系列适用于各种应用场合适用于恶劣环境的便携设备。HS300x系列数字传感器测量精度较高湿度和温度水平。测量数据在内部修正和补偿了广泛的准确操作温度和湿度等级范围-用户校准不是必需的。

功能:精确读取环境温湿度数据。

软件说明

单片机部分:使用keil软件创建单片机工程

部分代码:

void UsartInit() //串口初始化

{

SCON=0X50;

T2L=(65536-(FOSC/4/BAUD));

T2H=(65536-(FOSC/4/BAUD))>>8;

AUXR = 0x14;

AUXR|=0x01;

ES=1;

EA=1;

}

void sensor_data()//IIC读取函数

{

I2cStart();

I2cSendByte(0x89);

Humidity_H_data=I2cReadByte();

Ack();

Humidity_L_data=I2cReadByte();

Ack();

Temp_H_data=I2cReadByte();

Ack();

Temp_L_data=I2cReadByte();

NoAck();

I2cStop();

}

void transform()//数据计算函数

{

TH=Temp_H_data*64+(Temp_L_data>>2)-4000;

RH=((Humidity_H_data&0x3f)*256+Humidity_L_data)/1.64;

Humidity_H_data=RH/100;

Humidity_L_data=RH%100;

Temp_H_data=TH/100;

Temp_L_data=TH%100;

}

while(1)//主循环函数

{

sensor_data();

transform();

Usart_send();

delay500ms();

}

2.服务器部分:使用易语言软件编辑应用

部分代码:

.版本 2


.程序集 窗口程序集_启动窗口


.子程序 __启动窗口_创建完毕


服务器1.禁止 = 真


.子程序 _服务器1_数据到达

.局部变量 flag, 整数型

.局部变量 num, 整数型


num = 列表框1.取项目数 () - 1

flag = 列表框1.选择 (服务器1.取回客户 ())

.判断循环首 (num ≥ 0)

    .如果真 (num ≠ flag)

        服务器1.发送数据 (列表框1.取项目文本 (num), 服务器1.取回数据 (), )

    .如果真结束

    num = num - 1

.判断循环尾 ()

.如果 (led_flag = 1)

    标签2.背景颜色 = #灰色

    led_flag = 0

.否则

    标签2.背景颜色 = #绿色

    led_flag = 1

.如果结束



.子程序 _服务器1_客户进入


列表框1.加入项目 (服务器1.取回客户 (), )


.子程序 _服务器1_客户离开


列表框1.删除项目 (列表框1.选择 (服务器1.取回客户 ()))

列表框1.刷新显示 ()


.子程序 _按钮1_被单击


服务器1.端口 = 到整数 (编辑框1.内容)

按钮1.标题 = “已启用”

按钮1.禁止 = 真

服务器1.禁止 = 假

3.手机APP端:使用易安卓软件编辑工程

部分代码:

变量 温湿度数据 为 字节型(8)

变量 数组下标 为 整数型

变量 数据开关 为 整数型

事件 主窗口.创建完毕()

客户1.连接服务器("47.107.33.250",8888,5000)

数组下标=0

结束 事件


事件 客户1.连接完毕(连接结果 为 逻辑型)

弹出提示("服务器连接成功")

结束 事件


事件 客户1.连接断开()

弹出提示("服务器连接已断开")

结束 事件


事件 客户1.收到数据(数据 为 字节型())

变量 收到的数据 为 字节型(6)

收到的数据=数据

如果 收到的数据(0)=1 且 收到的数据(5)=2 则

弹出提示("收到数据")

如果 收到的数据(1)<95 则

标签4.标题=整数到文本(收到的数据(1))&"."&整数到文本(收到的数据(2))

否则

结束 如果

如果 收到的数据(3)<30 则

标签6.标题=整数到文本(收到的数据(3))&"."&整数到文本(收到的数据(4))

否则

结束 如果

否则

结束 如果

结束 事件


事件 主窗口.按下某键(键代码 为 整数型,传址 屏蔽 为 逻辑型)

如果 键代码 = 返回键 则

客户1.断开连接()

    结束程序()

结束 如果

结束 事件


事件 选择框1.选择改变()

变量 命令 为 字节型(1)

如果 选择框1.选中=真 则

命令(0)=1

否则

    命令(0)=2

结束 如果

客户1.发送数据(命令)

结束 事件


演示效果


评论区(4 )
  • 葬花佛: 18222005391微信手机同号,楼主看到的话请联系我一下

    回复

  • tjdpuc4r: 光子脱毛仪的使用寿命一般在30万次至70万次。
    激光脱毛仪的使用寿命则是在3000万次至6000万次。
    使用次数大大多于光子脱毛仪,可以供更多人完成全身脱毛
    那么光子脱毛及激光脱毛仪的工作原理是什么呢?
    光子脱毛仪释放宽谱波段光,能量分散,到达毛囊的能量较少。
    激光脱毛仪释放单色性、方向性纯光,能够透过皮肤表层到达毛囊根部。

    回复

  • xulilaopo123: 18931429731,楼主看到请麻烦联系下我

    回复

  • fansnew: 怎么判断猪有没有生病

    回复