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Chapter 1. Converting Designs 

Overview 
Eagle designs (Schematic and PCB) can be imported into DesignSpark, as can symbol, footprint and 
component libraries. 

Supported Versions of Eagle 
DesignSpark supports Eagle V5.x plus older versions back to V4.01 and V4.11. ULP files are supplied 
with DesignSpark and are used to export from Eagle format into an Intermediate ASCII format. 
These files are used as the import into DesignSpark by simply then opening them. 

Exporting Designs 
Both Schematic and PCB designs are exported in the same way from Eagle using the same menu 
options and ULP mechanism. The only difference is that one ULP file is run on Schematic design and 
the other run on the PCB design. 

 To export an Eagle design into an ASCII file 

1. Start Eagle from the Task bar or from a desktop icon if you have created one. 

2. From the Project Manager, select the Open option from the File menu. 

3. Under Open >, choose Schematic or Board (PCB). This will depend on the design you wish to 
convert. 

4. Locate the folder and file you wish to convert. 

 

5. Select it and click Open. 

6. The design will be displayed in the Schematic (or Board) editor. 

7. You now need to convert the design to an Intermediate ASCII file format. 

8. From the design editor toolbar, select the ULP icon (just under the Options menu item). 

9. A Run window will open. From here, select the appropriate ULP file supplied for DesignSpark. 

10. You will have to navigate away from the default Eagle ULP folder and locate the 
DesignSpark/EagleULP folder under which you will find the DesignSpark ULP files listed. 

11. For a Schematic design, you will need to select the SchematicToIntermediate.ulp file. 

12. If converting a PCB design, select the PcbToIntermediate.ulp file. 
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13. Once selected, click the Open button. 

14. Choose the folder and file name of the intermediate file. By default, the folder and filename 
chosen will be for the folder and filename of the open Eagle design. 

 

15. If you open and convert a Schematic design, the file extension will be .eis. If you opened a 
Board (PCB) file, the file extension will be .eip. 

16. Click Save. The intermediate file (.eis or .eip) is written and will now be ready to import into 
DesignSpark. 

17. Depending on the design size, the ULP file may take a few moments to run. 

18. Watch the status bar at the bottom of the Eagle design, it will show you the progress as it runs. 
Once completed, the status changes to Run: SchematicToIntermediate.ulp: finished 
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Importing Eagle Designs into DesignSpark 
Now you must take the Intermediate ASCII file created in Eagle and import it into DesignSpark. 

 To import an Eagle design into DesignSpark 

1. Run DesignSpark 

2. From the File menu, select Import 

3. Locate the folder that contains the intermediate file and select it. 

 

4. A small dialog will appear from which to add a file name and choose a Technology file. This 
dialog will be the same for a Schematic or PCB file except it will automatically reflect the 
detected design type. 

 

5. Choose a file name or leave the name currently pre-set to the imported design name. 

6. Unless you know what you’re doing and have specific requirements, choose [None] as the 
technology file name. One is not mandatory for the conversion. 

7. Click OK to import the design. 

8. DesignSpark will redraw the design on the screen. This is now ready to use and edit as you 
wish. 

9. Remember to save the design using the Save option from the File menu. 

Limitations on Design Transfer 
You should find that most designs should transfer to DesignSpark without any issues. However, 
there are a couple of limitations in Eagle to be aware of, as they may result in apparent errors in the 
corresponding DesignSpark PCB design. 

PCB Spacings 
The Spacing rules (clearances) defined in an Eagle PCB design are not accessible to the ULP script, 
so they cannot be transferred to DesignSpark. If you find that Design Rule Check in DesignSpark 
flags up many more errors than you would expect, you should check the settings in your Spacings 
in the Design Technology dialog. These should be edited to match the original settings from Eagle. 

Unfinished Tracks 
It is possible in Eagle to ‘end’ a track before it reaches the ‘connect point’ of a pad. On transfer to 
DesignSpark this kind of track will show up (on the screen and in Design Rule Check) as an 
‘unfinished track’. This is not necessarily a problem, as the Design Rule Check will still check for 
completeness of the circuit as long as the track touches the pad, but you may again see more DRC 
errors than you might normally expect. These can be manually edited if you wish to remove them.
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Chapter 2. Converting Libraries 

Eagle Library Structure 
Eagle library files (.lbr) contain Schematic symbols, PCB footprints and Part/Component information 
all in one self contained file. 

DesignSpark uses individual files for each library type Schematic symbols, PCB footprints and 
Part/Components. Therefore, during conversion, the one Eagle library file (and subsequent 
intermediate .eil file) is converted into separate DesignSpark files. 

Exporting Libraries 
Each library required for conversion is exported using a ULP file to convert the library into an 
intermediate format file (.eil). There are not separate ULP files for the different library types, just 
the one. 

 To export an Eagle library into an ASCII file 

1. Start Eagle from the Task bar or from a desktop icon if you have created one. 

2. From the Project Manager, select the Open option from the File menu. 

3. Under Open >, choose Library.  

4. Using the Open dialog, locate the folder and select the library to convert. 

 

5. Click Open. 

6. The library will open but nothing will be displayed at this point as this is the Library Manager 
from where you would edit and create the library entities. 

7. You now need to convert the library to an Intermediate ASCII file format. 

8. From the Library Editor toolbar, select the ULP icon (just under the Library and Options menu 
items). 

9. A Run window will open. From here, select the appropriate ULP file supplied for DesignSpark. 

10. You will have to navigate away from the default Eagle ULP folder and locate the 
DesignSpark/EagleULP folder under which you will find the DesignSpark ULP files listed. 

11. Select the LibraryToIntermediate.ulp file. 



8   Chapter 2 – Importing Libraries 

 

12. Once selected, click the Open button. 

13. Choose the folder and file name of the intermediate file. By default, the folder and filename 
chosen will be for the folder and filename of the open Eagle library. 

 

14. It will request you select a .eil file. 

15. Click Save. The intermediate file (.eil) is written and will now be ready to import into 
DesignSpark. 

16. Depending on the library size, the ULP file may take a few moments to run. 

17. Watch the status bar at the bottom of the Eagle design, it will show you the progress as it runs. 
Once completed, the status changes to Run: LibraryToIntermediate.ulp: finished 



 Chapter 2 – Importing Libraries   9 

Importing Libraries into DesignSpark 
As we said above, the one intermediate file for each Eagle library file must be read into three 
separate DesignSpark files to create to necessary library facets. To do this you must use the one .eil 
file and import it three times to each of the DesignSpark libraries (Schematic Symbol, PCB Footprint 
and Component). The procedure below details this for each type but it is actually the same for each. 

Importing an Intermediate file to create Schematic Symbols 

 To import an Intermediate file to create Schematic Symbols 

1. Run DesignSpark 

2. From the File menu choose Libraries. 

3. Click on the Schematic Symbols tab. 

 

4. Click on the New Lib button. You will create a new library into which you will convert the Eagle 
library. 

 

5. Type the name of the new library. You do not need to enter a file extension, it will automatically 
assign one for you. 

6. Click the Save button. 

7. The new empty library is displayed. 
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8. You will now convert and add the Eagle .eil file. 

9. Click the Add File button. 

 

10. From the Open dialog, select the .eil file to import. Don’t forget, this file will be used three times 
to create the three corresponding libraries. 

11. Press Open. 

 

12. The import mechanism will automatically detect an Eagle library file. 

13. The Eagle file is self-contained, you do not need to use a Technology file. You can use one if you 
wish to apply standardized names or colours.  

14. Select the Technology file Name as [None]. 

15. Press the OK button. 

16. A progress bar will be displayed. Depending on how big the library being imported is, this may 
time a few moments to run. 
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17. Your library will open and be displayed in the Library Contents list. 

 

18. To run a quick visual check on the contents, select one of the items in the Library Contents list. 
Click the Preview button and the symbol will be displayed. 

19. If you have more than one library to convert, repeat the procedure again from step 4. 
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Importing an Intermediate file to create PCB Footprints 

 To import an Intermediate file to create PCB Footprints 

1. Run DesignSpark 

2. From the File menu choose Libraries. 

3. Click on the PCB Symbols tab. 

 

4. Click on the New Lib button. You will create a new library into which you will convert the Eagle 
library. 

 

5. Type the name of the new library. You do not need to enter a file extension, it will automatically 
assign one for you. For a PCB Symbol library you may well add multiple intermediate files 
together to rationalise the footprints. 

6. Click the Save button. 

7. The new empty library is displayed. 
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8. You will now convert and add the Eagle .eil file. 

9. Click the Add File button. 

 

10. From the Open dialog, select the .eil file to import. Don’t forget, this file has already been used, 
this if fine, it will be used one time more as well after this. 

11. Press Open. 

 

12. The import mechanism will automatically detect an Eagle library file. 

13. The Eagle file is self-contained, you do not need to use a Technology file. You can use one if you 
wish to apply standardized names or colours.  

14. Select the Technology file Name as [None]. 

15. Press the OK button. 
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16. A progress bar will be displayed. Depending on how big the library being imported is, this may 
time a few moments to run. 

17. Your library will open and be displayed in the Library Contents list. 

 

18. To run a quick visual check on the contents, select one of the items in the Library Contents list. 
Click the Preview button and the symbol will be displayed. 

19. If you have more than one library to convert, repeat the procedure again from step 4. but this 
time, you may need to observe the note in step 5. 
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Importing an Intermediate file to create Components 

 To import an Intermediate file to create Components 

1. Run DesignSpark 

2. From the File menu choose Libraries. 

3. Click on the Components tab. 

 

4. Click on the New Lib button. You will create a new library into which you will convert the Eagle 
library. 

 

5. Type the name of the new library. You do not need to enter a file extension, it will automatically 
assign one for you. 

6. Click the Save button. 

7. The new empty library is displayed. 
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8. You will now convert and add the Eagle .eil file. 

9. Click the Add File button. 

 

10. From the Open dialog, select the same .eil file to import, this is one that has already been used. 

11. Press Open. 

12. The import mechanism will automatically detect an Eagle library file and launch straight into the 
importing. 

13. A progress bar is displayed. Depending on how big the file is will depend on how long it is shown 
for, don’t be surprised if you miss it. 

 

14. A progress bar will be displayed. Depending on how big the library being imported is, this may 
time a few moments to run. 

15. Your library will open and be displayed in the Library Contents list. 
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16. To run a quick visual check on the contents, select one of the items in the Library Contents list. 
Click the Preview button and the symbols plus the Component information will be displayed. 

17. Check that the symbols are as expected and that the footprint is the correct type for the 
Component. 

18. Importing the Component is the final operation to be done before you use it in either the 
Schematic or PCB designs. 

19. If you have more than one library to convert, repeat the procedure again from step 4. 


